Search found 8 matches

by GBradburn
Tue Oct 05, 2010 1:16 am
Forum: SUB-20 General Discussion
Topic: Level Converter not Level I Ordered?
Replies: 11
Views: 25607

Re: Level Converter not Level I Ordered?

Hi,

Thank you for sticking with me on this issue. The correct method for updating the firmware was the last piece of the puzzle and I am now able to communicate with my device using the SUB-20 and the 1.2V level converter.

Regards,

Greg
by GBradburn
Tue Sep 28, 2010 4:15 pm
Forum: SUB-20 General Discussion
Topic: Level Converter not Level I Ordered?
Replies: 11
Views: 25607

Re: Level Converter not Level I Ordered?

After reviewing your note above maybe I still don't understand the versioning. After installing from the second link in your response above I get: sub_app.exe --version XDimax LTD, V0.1.6, SEP 23 2010 00:04:11 DLL/LIB: 0.0.2.18 Driver : 0.0.2.0 SUB-20: 0.2.2 Boot : 0.5 This looks like I still don't ...
by GBradburn
Tue Sep 28, 2010 4:09 pm
Forum: SUB-20 General Discussion
Topic: Level Converter not Level I Ordered?
Replies: 11
Views: 25607

Re: Level Converter not Level I Ordered?

Hi,

Note that these two links point to different versions and I misunderstood the versioning convention. I actually do have the latest version (0.2.2 as noted in my previous post) and I still have the issue of not being able to communicate with an MDIO device at 1.2V.

Please help.

Regards,
Greg
by GBradburn
Tue Sep 28, 2010 1:45 am
Forum: SUB-20 General Discussion
Topic: Level Converter not Level I Ordered?
Replies: 11
Views: 25607

Re: Level Converter not Level I Ordered?

Hi,

sub_app.exe --version
XDimax LTD, V0.1.6, Aug 17 2010 21:56:51
DLL/Lib: 0.0.2.18
Driver : 0.0.2.0
SUB-20 : 0.2.2
Boot : 0.5

It looks like I have an older SUB-20 driver. Where do I find the update and how do I install it?

Thanks,

Greg
by GBradburn
Fri Sep 24, 2010 11:07 pm
Forum: SUB-20 General Discussion
Topic: Level Converter not Level I Ordered?
Replies: 11
Views: 25607

Re: Level Converter not Level I Ordered?

In addition to the previous post, here are some more specific questions which I can't find answers for on the web site or in the manual: I am trying to use MDIO to communicate to an MDIO clause 45 compliant device operating at 1.2V. I special ordered 5 SUB-20 devices with 1.2V level converters. The ...
by GBradburn
Fri Sep 24, 2010 3:43 pm
Forum: SUB-20 General Discussion
Topic: SUB-20 and NI LabView
Replies: 6
Views: 233057

Re: SUB-20 and NI LabView

Does the .NET support include the latest rev of the software, including support for MDIO through the level converters (MDIO1/MDC1)?
by GBradburn
Fri Sep 24, 2010 1:39 am
Forum: SUB-20 General Discussion
Topic: Level Converter not Level I Ordered?
Replies: 11
Views: 25607

Re: Level Converter not Level I Ordered?

Thanks for your help. I have made the connections you have indicated: Jumper JP6 2-3 and 1.2V reference to J6.9. I now see 1.2V on the MDC1 and MDIO1 lines. From the command prompt I issue the command: Sub_app.exe --mdio=1a,0x1F,0x01,0xA011 --mdio=1r,0x1f,0x01,0xA011 I am expecting this to achieve t...
by GBradburn
Wed Sep 22, 2010 10:39 pm
Forum: SUB-20 General Discussion
Topic: Level Converter not Level I Ordered?
Replies: 11
Views: 25607

Level Converter not Level I Ordered?

Hi, I ordered several SUB-20 devices with 1.2V level converter for MDIO communications. After having no success with the device I measured the voltage levels on pins 1 and 7 of J6 (MDC1 and MDIO1) and found 3.3V. Do I need to connect a reference voltage to the device or did I just not get what I ord...